1

Topic: esp8266-01 connection problem

hi to everyone thanks for this application.. im using hardserial on my projects sometimes electrics goes and something happening esp8266-01 cannot connecting to enternet.. likely 20 times blue led flashing for connect but it cant becoz there is no avaiable network. then it passing from setup mode to loop mode and my board never connect to network again.. yes it works all codes true but if at first period of working cannot connect to network then i must reset board for when enternet network avaiable again..  how we can solve this problem i need your helps.. thanks againn...

2

Re: esp8266-01 connection problem

hamidow172494 wrote:

hi to everyone thanks for this application.. im using hardserial on my projects sometimes electrics goes and something happening esp8266-01 cannot connecting to enternet.. likely 20 times blue led flashing for connect but it cant becoz there is no avaiable network. then it passing from setup mode to loop mode and my board never connect to network again.. yes it works all codes true but if at first period of working cannot connect to network then i must reset board for when enternet network avaiable again..  how we can solve this problem i need your helps.. thanks againn...

You most likely need to delay applying power to the ESP module, or hold it in "Not Enabled", to give your router chance to re-connect to your ISP.  You could do this in your void setup(), which would then drive an output to allow the ESP to start up.

I'm not that familiar with ESP programming, but can you not turn off the automatic switchover to Loop mode ?

Everything works with smoke - if you let it out, things stop working....

3

Re: esp8266-01 connection problem

im going to use WDT at void setup() i will try it today or tomorrow on my code and it will be like;

AT
AT
AT... atmega328 will try this for connect esp8266 to network and its just 20times repeating AT command if esp8266 dont answer AT=OK

till that seconds must connect to network or pass to the void loop()

if there is connection it will use it in 6 seconds if there is no connection it will try till 20times AT command but after 8seconds watch dog timer will see there is no report back from board then will reset by automaticly till avaiable network there. For now this came to my mind but i will try yours too in codes and which one healthy i will share with you my friend thanks again..